[Global] Canvas integrations partially unavailable

Incident Report for FeedbackFruits

Monitoring

Educators launching FeedbackFruits learning activities in Canvas environments using the 'inherited API key' will now be asked to provide permissions to FeedbackFruits. After granting these permissions, the synchronization for course data for their courses will recover.

Scheduled grade pushes for activities in affected courses will not succeed, until at least one educator has opened a FeedbackFruits activity in an affected course.

In the permissions screen, users might see "FeedbackFruits - 2026-04-30 22:24:18 UTC" instead of just "FeedbackFruits". This is a (temporary) side effect of the mitigation put in place by Instructure.

All affected partners (those using 'inherited API key' configurations for FeedbackFruits in Canvas) have received an email from us earlier today.

We will monitor recovery and work with Instructure to evaluate this event.
Posted May 01, 2026 - 13:32 UTC

Update

The issue is still ongoing. We have now received an initial reply from Instructure and are awaiting further clarity.
Posted May 01, 2026 - 12:39 UTC

Update

Educators no longer get stuck while launching FeedbackFruits activities in Canvas when using the 'inherited API key' configuration, as our workaround is now in place. Synchronization of course data will remain unavailable for these configurations until the underlying issue is resolved by Instructure. We'll provide updates on our progress in resolving this matter with Instructure.
Posted May 01, 2026 - 08:01 UTC

Identified

We are implementing a workaround to prevent educators getting stuck while launching FeedbackFruits activities in Canvas, when using the 'inherited API key' configuration. Synchronization of course data will remain unavailable for these configurations until the underlying issue is resolved by Instructure. We'll provide an update once the workaround is in place.
Posted May 01, 2026 - 07:27 UTC

Investigating

We are investigating issues with Canvas integrations that depend on an API integration. Synchronization of course data (groups, enrollments, grade data) is affected, educators launching FeedbackFruits activities can get stuck giving permission in Canvas.
Posted May 01, 2026 - 07:08 UTC
This incident affects: Europe (API), United States (API), Australia (API), and Canada (API).